import re
regex = re.compile(r"\b\d{1,2}[- /]+\d{1,2}[- /]+\d{2,4}")
test_str = ("im trying to retrieve a date from a string. the problem is that the pattern of this date varies a lot (string comes from an OCR reading). These are the patterns i need to identify:\n\n"
" 11/11/1111 (i can get this one already)\n"
" 11-11-1111 (i can get this one already)\n"
" 11 11 1111 (i can get this one already)\n"
" 11- 11- 1111\n"
" 11 11 1111\n"
" 11-11 1111\n"
" 23- 10-17\n"
" 9 06- 17\n")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")