re = /\b\d{1,2}[- \/]+\d{1,2}[- \/]+\d{2,4}/
str = 'im trying to retrieve a date from a string. the problem is that the pattern of this date varies a lot (string comes from an OCR reading). These are the patterns i need to identify:
11/11/1111 (i can get this one already)
11-11-1111 (i can get this one already)
11 11 1111 (i can get this one already)
11- 11- 1111
11 11 1111
11-11 1111
23- 10-17
9 06- 17
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end