package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)(\d\D?){10}\b`)
var str = `02-15-87-96-54
1234567890
02-02-024589
023-023-0254`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}