$re = '/(\d\D?){10}\b/m';
$str = '02-15-87-96-54
1234567890
02-02-024589
023-023-0254';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);