import re
regex = re.compile(r"(\d\D?){10}\b", flags=re.MULTILINE)
test_str = ("02-15-87-96-54\n"
"1234567890 \n"
"02-02-024589 \n"
"023-023-0254")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")