#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?mx)\w+@" & @CRLF & _
"([-a-zA-Z\d.]{1,61})\.[a-zA-Z]{2,4}"
Local $sString = "a@b.cde." & @CRLF & _
"" & @CRLF & _
"Va$ya123@..ruuuuuuuuuuuuuuuuuuuuuuuuu" & @CRLF & _
"andrey@mail.t.com.ua" & @CRLF & _
"____________________________________________________________________@.ru" & @CRLF & _
"as@m.t.tu"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")