$re = '/\w+@
([-a-zA-Z\d.]{1,61})\.[a-zA-Z]{2,4}/mx';
$str = 'a@b.cde.
Va$ya123@..ruuuuuuuuuuuuuuuuuuuuuuuuu
andrey@mail.t.com.ua
____________________________________________________________________@.ru
as@m.t.tu';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);