// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?mx)\w+@
([-a-zA-Z\d.]{1,61})\.[a-zA-Z]{2,4}").unwrap();
let string = "a@b.cde.
Va$ya123@..ruuuuuuuuuuuuuuuuuuuuuuuuu
andrey@mail.t.com.ua
____________________________________________________________________@.ru
as@m.t.tu";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}