re = /\w+@
([-a-zA-Z\d.]{1,61})\.[a-zA-Z]{2,4}/mx
str = 'a@b.cde.
Va$ya123@..ruuuuuuuuuuuuuuuuuuuuuuuuu
andrey@mail.t.com.ua
____________________________________________________________________@.ru
as@m.t.tu'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end