#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^(?!.*\/s\/123)(?!.*\/s\/32A )(?!.*atr\/will)([\/a-zA-Z]*)\/_MyWord\/(.*)$"
Local $sString = "/s/123/QWERERTYU/_MyWord/45454545" & @CRLF & _
"atr/will/DFGH/FGHJK/GHJK/_MyWord/DFGHJ452" & @CRLF & _
"/DFGH/FGHJK/GHJK/_MyWord/DFGHJ452" & @CRLF & _
"HiCanYouHelpMe/_MyWord/fgh" & @CRLF & _
"/_MyWord/HiCanYouHelpMefgh" & @CRLF & _
"" & @CRLF & _
"I am handling user input in my program by using regular exp." & @CRLF & _
"" & @CRLF & _
"the string contains /_MyWord/ and only a-z is accepted before /_MyWord/." & @CRLF & _
"the string not contain /s/123, /s/32A and atr/will in the beginning." & @CRLF & _
"My try:" & @CRLF & _
"" & @CRLF & _
"^(?!.*/s/123)(?!.*/s/32A )(?!.*atr/will)([/a-z]+)/_MyWord/(.*)$" & @CRLF & _
"Example:" & @CRLF & _
"" & @CRLF & _
"/s/123/QWERERTYU/_MyWord/45454545 -> fail" & @CRLF & _
"/DFGH/FGHJK/GHJK/_MyWord/DFGHJ452 -> OK" & @CRLF & _
"HiCanYouHelpMe/_MyWord/fgh -> OK" & @CRLF & _
"/_MyWord/HiCanYouHelpMefgh -> OK"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")