# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"^(?!.*\/s\/123)(?!.*\/s\/32A )(?!.*atr\/will)([\/a-zA-Z]*)\/_MyWord\/(.*)$"
test_str = ("/s/123/QWERERTYU/_MyWord/45454545\n"
"atr/will/DFGH/FGHJK/GHJK/_MyWord/DFGHJ452\n"
"/DFGH/FGHJK/GHJK/_MyWord/DFGHJ452\n"
"HiCanYouHelpMe/_MyWord/fgh\n"
"/_MyWord/HiCanYouHelpMefgh\n\n"
"I am handling user input in my program by using regular exp.\n\n"
"the string contains /_MyWord/ and only a-z is accepted before /_MyWord/.\n"
"the string not contain /s/123, /s/32A and atr/will in the beginning.\n"
"My try:\n\n"
"^(?!.*/s/123)(?!.*/s/32A )(?!.*atr/will)([/a-z]+)/_MyWord/(.*)$\n"
"Example:\n\n"
"/s/123/QWERERTYU/_MyWord/45454545 -> fail\n"
"/DFGH/FGHJK/GHJK/_MyWord/DFGHJ452 -> OK\n"
"HiCanYouHelpMe/_MyWord/fgh -> OK\n"
"/_MyWord/HiCanYouHelpMefgh -> OK")
matches = re.finditer(regex, test_str, re.MULTILINE)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.