using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(cache)(.*)(\.jpg|\.png|.jpeg)";
string input = @"cache/folder1/tester/kartinka.png-270x270.jpeg
cache/folder1/tester/kartinka.png";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}