package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?Um)(cache)(.*)(\.jpg|\.png|.jpeg)`)
var str = `cache/folder1/tester/kartinka.png-270x270.jpeg
cache/folder1/tester/kartinka.png`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}