// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?Um)(cache)(.*)(\.jpg|\.png|.jpeg)").unwrap();
let string = "cache/folder1/tester/kartinka.png-270x270.jpeg
cache/folder1/tester/kartinka.png";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}