$re = '/(cache)(.*)(\.jpg|\.png|.jpeg)/Um';
$str = 'cache/folder1/tester/kartinka.png-270x270.jpeg
cache/folder1/tester/kartinka.png';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);