import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "href=\"?(https:\\/\\/fpd\\-shopify\\-v2\\.herokuapp\\.com\\/api.*?)\"";
final String string = "<a href=\"https://fpd-shopify-v2.herokuapp.com/api/fe/line_item_cache_print_pdf/12345-67890abcdefg12345\" style=\"margin-top:0;margin-bottom:0;color:#2c6ecb;text-decoration:none;padding:0\" target=\"_blank\" data-saferedirecturl=\"https://www.google.com/url?q=https://fpd-shopify-v2.herokuapp.com/api/fe/line_item_cache_print_pdf/12345-67890abcdefg12345&source=gmail&ust=123456789&usg=ABCDE12345\">Download Print PDF</a><a href=\"https://fpd-shopify-v2.herokuapp.com/api/fe/line_item_cache_print_pdf/abcdefg1234567\" style=\"margin-top:0;margin-bottom:0;color:#2c6ecb;text-decoration:none;padding:0\" target=\"_blank\" data-saferedirecturl=\"https://www.google.com/url?q=https://fpd-shopify-v2.herokuapp.com/api/fe/line_item_cache_print_pdf/abcdefg1234567&source=gmail&ust=123456789&usg=ABCDE12345\">Download Print PDF</a>\n\n";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}