import Foundation
let pattern = #"href="?(https:\/\/fpd\-shopify\-v2\.herokuapp\.com\/api.*?)""#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = ##"""
<a href="https://fpd-shopify-v2.herokuapp.com/api/fe/line_item_cache_print_pdf/12345-67890abcdefg12345" style="margin-top:0;margin-bottom:0;color:#2c6ecb;text-decoration:none;padding:0" target="_blank" data-saferedirecturl="https://www.google.com/url?q=https://fpd-shopify-v2.herokuapp.com/api/fe/line_item_cache_print_pdf/12345-67890abcdefg12345&source=gmail&ust=123456789&usg=ABCDE12345">Download Print PDF</a><a href="https://fpd-shopify-v2.herokuapp.com/api/fe/line_item_cache_print_pdf/abcdefg1234567" style="margin-top:0;margin-bottom:0;color:#2c6ecb;text-decoration:none;padding:0" target="_blank" data-saferedirecturl="https://www.google.com/url?q=https://fpd-shopify-v2.herokuapp.com/api/fe/line_item_cache_print_pdf/abcdefg1234567&source=gmail&ust=123456789&usg=ABCDE12345">Download Print PDF</a>
"""##
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)