use strict;
my $str = '<a href="https://fpd-shopify-v2.herokuapp.com/api/fe/line_item_cache_print_pdf/12345-67890abcdefg12345" style="margin-top:0;margin-bottom:0;color:#2c6ecb;text-decoration:none;padding:0" target="_blank" data-saferedirecturl="https://www.google.com/url?q=https://fpd-shopify-v2.herokuapp.com/api/fe/line_item_cache_print_pdf/12345-67890abcdefg12345&source=gmail&ust=123456789&usg=ABCDE12345">Download Print PDF</a><a href="https://fpd-shopify-v2.herokuapp.com/api/fe/line_item_cache_print_pdf/abcdefg1234567" style="margin-top:0;margin-bottom:0;color:#2c6ecb;text-decoration:none;padding:0" target="_blank" data-saferedirecturl="https://www.google.com/url?q=https://fpd-shopify-v2.herokuapp.com/api/fe/line_item_cache_print_pdf/abcdefg1234567&source=gmail&ust=123456789&usg=ABCDE12345">Download Print PDF</a>
';
my $regex = qr/href="?(https:\/\/fpd\-shopify\-v2\.herokuapp\.com\/api.*?)"/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}