re = /href="?(https:\/\/fpd\-shopify\-v2\.herokuapp\.com\/api.*?)"/m
str = '<a href="https://fpd-shopify-v2.herokuapp.com/api/fe/line_item_cache_print_pdf/12345-67890abcdefg12345" style="margin-top:0;margin-bottom:0;color:#2c6ecb;text-decoration:none;padding:0" target="_blank" data-saferedirecturl="https://www.google.com/url?q=https://fpd-shopify-v2.herokuapp.com/api/fe/line_item_cache_print_pdf/12345-67890abcdefg12345&source=gmail&ust=123456789&usg=ABCDE12345">Download Print PDF</a><a href="https://fpd-shopify-v2.herokuapp.com/api/fe/line_item_cache_print_pdf/abcdefg1234567" style="margin-top:0;margin-bottom:0;color:#2c6ecb;text-decoration:none;padding:0" target="_blank" data-saferedirecturl="https://www.google.com/url?q=https://fpd-shopify-v2.herokuapp.com/api/fe/line_item_cache_print_pdf/abcdefg1234567&source=gmail&ust=123456789&usg=ABCDE12345">Download Print PDF</a>
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end