using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"cig[\s:.]*(\S(?:\s*\S){9})(?!\S)";
string input = @"/BENEF/FORNITURA GAS FEB-20 CIG Z9F 27D2198 01762-0000031";
RegexOptions options = RegexOptions.Multiline | RegexOptions.IgnoreCase;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}