import re
regex = re.compile(r"cig[\s:.]*(\S(?:\s*\S){9})(?!\S)", flags=re.MULTILINE | re.IGNORECASE)
test_str = "/BENEF/FORNITURA GAS FEB-20 CIG Z9F 27D2198 01762-0000031"
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")