const regex = new RegExp('cig[\\s:.]*(\\S(?:\\s*\\S){9})(?!\\S)', 'gmi')
const str = `/BENEF/FORNITURA GAS FEB-20 CIG Z9F 27D2198 01762-0000031`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}