package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^[1][0][0]\.[0]{2}\%|[1-9]?[0-9]\.[0-9]{2}\%$`)
var str = `Valid:
100.00%
2.00%
22.00%
2.99%
invalid:
02.00%
110.00%
200.00%`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}