// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)^[1][0][0]\.[0]{2}\%|[1-9]?[0-9]\.[0-9]{2}\%$").unwrap();
let string = "Valid:
100.00%
2.00%
22.00%
2.99%
invalid:
02.00%
110.00%
200.00%";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}