use strict;
my $str = 'Valid:
100.00%
2.00%
22.00%
2.99%
invalid:
02.00%
110.00%
200.00%';
my $regex = qr/^[1][0][0]\.[0]{2}\%|[1-9]?[0-9]\.[0-9]{2}\%$/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}