$re = '/^[1][0][0]\.[0]{2}\%|[1-9]?[0-9]\.[0-9]{2}\%$/m';
$str = 'Valid:
100.00%
2.00%
22.00%
2.99%
invalid:
02.00%
110.00%
200.00%';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);