$re = '/(?<=(.))(?!\1)(?=.)/m';
$str = 'CEEEETTEEEEGGGCCBCTTBHHHHHCCEEEEEEEEETTEETT';
$subst = " ";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;