import re
regex = re.compile(r"(?<=(.))(?!\1)(?=.)", flags=re.MULTILINE)
test_str = "CEEEETTEEEEGGGCCBCTTBHHHHHCCEEEEEEEEETTEETT"
subst = " "
result = regex.sub(subst, test_str)
if result:
print(result)