re = /(?<=(.))(?!\1)(?=.)/m
str = 'CEEEETTEEEEGGGCCBCTTBHHHHHCCEEEEEEEEETTEETT'
subst = ' '
result = str.gsub(re, subst)
# Print the result of the substitution
puts result