using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^\w{1,15}\_[A-Za-z0-9]{8,}$";
string input = @"price_0KxBDl589O8KAxCG1alJgiA6";
Match m = Regex.Match(input, pattern);
Console.WriteLine("'{0}' found at index {1}", m.Value, m.Index);
}
}