import Foundation
let pattern = #"^\w{1,15}\_[A-Za-z0-9]{8,}$"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"price_0KxBDl589O8KAxCG1alJgiA6"#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
if let firstMatch = regex.firstMatch(in: testString, range: stringRange) {
let result: [String] = (1 ..< firstMatch.numberOfRanges).map { (testString as NSString).substring(with: firstMatch.range(at: $0)) }
print(result)
} else {
print("No matches were found.")
}