$re = '/^\w{1,15}\_[A-Za-z0-9]{8,}$/';
$str = 'price_0KxBDl589O8KAxCG1alJgiA6';
preg_match($re, $str, $matches, PREG_OFFSET_CAPTURE, 0);
// Print the entire match result
var_dump($matches);