package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`^\w{1,15}\_[A-Za-z0-9]{8,}$`)
var str = `price_0KxBDl589O8KAxCG1alJgiA6`
if len(re.FindStringIndex(str)) > 0 {
fmt.Println(re.FindString(str),"found at index",re.FindStringIndex(str)[0])
}
}