#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?<! )[-a-zA-Z' ]{2,26}"
Local $sString = " a--------'asdasdAASD" & @CRLF & _
" sdfsfsfsf--sdfdsfs'sdf" & @CRLF & _
"sddsfsfs08908fsdf" & @CRLF & _
"John Mc'Kenzie"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")