using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?<! )[-a-zA-Z' ]{2,26}";
string input = @" a--------'asdasdAASD
sdfsfsfsf--sdfdsfs'sdf
sddsfsfs08908fsdf
John Mc'Kenzie";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}