re = /(?<! )[-a-zA-Z' ]{2,26}/
str = ' a--------\'asdasdAASD
sdfsfsfsf--sdfdsfs\'sdf
sddsfsfs08908fsdf
John Mc\'Kenzie'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end