$re = '/(?<! )[-a-zA-Z\' ]{2,26}/';
$str = ' a--------\'asdasdAASD
sdfsfsfsf--sdfdsfs\'sdf
sddsfsfs08908fsdf
John Mc\'Kenzie';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);