import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(\\d+\\.\\d+)$";
final String string = "Болт с шест.гол. (DIN\n"
+ "933)\n"
+ " 0.111 х 5555.55=333.33\n"
+ "НДС 20% \n"
+ "ТОВАР \n"
+ "ПЕРЕДАЧА В КРЕДИТ \n\n"
+ "КОД СТРАНЫ:555 \n"
+ "ДЕКЛАРАЦИЯ:111111/22222/33333\n"
+ "ЕД.ИЗМЕРЕНИЯ:тыс. шт \n\n"
+ "Болт с шест.гол 2 (DIN\n"
+ "933)\n"
+ " 2.222 х 3333.33=7777.77\n"
+ "НДС 20% \n"
+ "ТОВАР \n"
+ "ПЕРЕДАЧА В КРЕДИТ \n\n"
+ "КОД СТРАНЫ:555 \n"
+ "ДЕКЛАРАЦИЯ:111111/22222/33333\n"
+ "ЕД.ИЗМЕРЕНИЯ:тыс. шт";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}