import re
regex = re.compile(r"(\d+\.\d+)$", flags=re.MULTILINE)
test_str = ("Болт с шест.гол. (DIN\n"
"933)\n"
" 0.111 х 5555.55=333.33\n"
"НДС 20% \n"
"ТОВАР \n"
"ПЕРЕДАЧА В КРЕДИТ \n\n"
"КОД СТРАНЫ:555 \n"
"ДЕКЛАРАЦИЯ:111111/22222/33333\n"
"ЕД.ИЗМЕРЕНИЯ:тыс. шт \n\n"
"Болт с шест.гол 2 (DIN\n"
"933)\n"
" 2.222 х 3333.33=7777.77\n"
"НДС 20% \n"
"ТОВАР \n"
"ПЕРЕДАЧА В КРЕДИТ \n\n"
"КОД СТРАНЫ:555 \n"
"ДЕКЛАРАЦИЯ:111111/22222/33333\n"
"ЕД.ИЗМЕРЕНИЯ:тыс. шт")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")