use strict;
my $str = 'Болт с шест.гол. (DIN
933)
0.111 х 5555.55=333.33
НДС 20%
ТОВАР
ПЕРЕДАЧА В КРЕДИТ
КОД СТРАНЫ:555
ДЕКЛАРАЦИЯ:111111/22222/33333
ЕД.ИЗМЕРЕНИЯ:тыс. шт
Болт с шест.гол 2 (DIN
933)
2.222 х 3333.33=7777.77
НДС 20%
ТОВАР
ПЕРЕДАЧА В КРЕДИТ
КОД СТРАНЫ:555
ДЕКЛАРАЦИЯ:111111/22222/33333
ЕД.ИЗМЕРЕНИЯ:тыс. шт';
my $regex = qr/(\d+\.\d+)$/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}