import re
regex = re.compile(r"(\w)(\w+)", flags=re.MULTILINE)
test_str = ("any word whatsoever\n"
"ANY WORD WHATSOEVER\n"
"aNy WoRd WhAtSoEvEr")
subst = "\\U$1\\E\\L$2"
result = regex.sub(subst, test_str)
if result:
print(result)