// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)(\w)(\w+)").unwrap();
let string = "any word whatsoever
ANY WORD WHATSOEVER
aNy WoRd WhAtSoEvEr";
let substitution = "\\U$1\\E\\L$2";
// result will be a String with the substituted value
let result = regex.replace_all(string, substitution);
println!("{}", result);
}