import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^GMT[+-]((0?[0-9]|1[0-1]):([0-5][0-9])|12:00)$";
final String string = "GMT+05:30\n"
+ "GMT+5:30\n"
+ "GMT+04:60\n"
+ "GMT+13:50\n"
+ "GMT+00:30\n"
+ "GMT+12:56\n"
+ "GMT+11:59\n"
+ "GMT+12:00\n"
+ "GMT-11:00\n"
+ "GMT+5.30\n";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}