const regex = /^GMT[+-]((0?[0-9]|1[0-1]):([0-5][0-9])|12:00)$/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^GMT[+-]((0?[0-9]|1[0-1]):([0-5][0-9])|12:00)$', 'gm')
const str = `GMT+05:30
GMT+5:30
GMT+04:60
GMT+13:50
GMT+00:30
GMT+12:56
GMT+11:59
GMT+12:00
GMT-11:00
GMT+5.30
`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}