// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)^GMT[+-]((0?[0-9]|1[0-1]):([0-5][0-9])|12:00)$").unwrap();
let string = "GMT+05:30
GMT+5:30
GMT+04:60
GMT+13:50
GMT+00:30
GMT+12:56
GMT+11:59
GMT+12:00
GMT-11:00
GMT+5.30
";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}