#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^(((([0-9]|[1-9][0-9]|1[0-9]{2}|2[0-4][0-9]|25[0-5])\.){3}([0-9]|[1-9][0-9]|1[0-9]{2}|2[0-4][0-9]|25[0-5]))|((([a-zA-Z]|[a-zA-Z][a-zA-Z0-9\-]*[a-zA-Z0-9])\.)+([A-Za-z|[A-Za-z][A-Za-z0-9\-]*[A-Za-z0-9])))$"
Local $sString = "foo" & @CRLF & _
"foo.bar" & @CRLF & _
"www.foo.bar" & @CRLF & _
"" & @CRLF & _
".foo" & @CRLF & _
"foo." & @CRLF & _
"foo.com." & @CRLF & _
".com.bar" & @CRLF & _
"" & @CRLF & _
"foo-bar.com" & @CRLF & _
"foo-bar.com-eu" & @CRLF & _
"foo.bar.com" & @CRLF & _
"" & @CRLF & _
"0.foo.bar" & @CRLF & _
"foo.1.bar" & @CRLF & _
"foo.bar.2" & @CRLF & _
".1.bar.com" & @CRLF & _
"" & @CRLF & _
"foo.bar1.com" & @CRLF & _
"foo.2bar.com" & @CRLF & _
"foo.bar3.com" & @CRLF & _
"foo.bar.4com" & @CRLF & _
"" & @CRLF & _
"127" & @CRLF & _
"127.0" & @CRLF & _
"127.0.0" & @CRLF & _
"127.0.0.1" & @CRLF & _
"" & @CRLF & _
".127" & @CRLF & _
".127.0" & @CRLF & _
".127.0.0" & @CRLF & _
".127.0.0.1" & @CRLF & _
"" & @CRLF & _
"8.8.8.8" & @CRLF & _
"8.8.4.4" & @CRLF & _
"" & @CRLF & _
"c:/" & @CRLF & _
"c:/foo/" & @CRLF & _
"c:/foo/bar/" & @CRLF & _
"" & @CRLF & _
"\\" & @CRLF & _
"\\foo" & @CRLF & _
"\\foo.bar" & @CRLF & _
"\\foo\bar" & @CRLF & _
"" & @CRLF & _
"http://regexp101.com" & @CRLF & _
"regexp101.com" & @CRLF & _
"www.regexp101.com" & @CRLF & _
"www.regexp101.com/"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")